Back to overview
Degraded

[Crystal Chaos] Survival Performance Degradation and Crashes

Aug 22 at 03:30am UTC
Affected services
Minecraft - Survival Server

Resolved
Aug 22 at 04:26am UTC

These issues have been resolved!

Created
Aug 22 at 03:30am UTC

We are currently investigating into performance issues and crashes with survival.